Fix the logic to support version 1.0.0!
authorAndrew Ruthven <andrew@etc.gen.nz>
Mon, 31 Dec 2018 09:20:28 +0000 (22:20 +1300)
committerAndrew Ruthven <andrew@etc.gen.nz>
Mon, 31 Dec 2018 09:20:28 +0000 (22:20 +1300)
Makefile

index 195d2ca..6367bf8 100755 (executable)
--- a/Makefile
+++ b/Makefile
@@ -12,7 +12,7 @@ build=dpkg-buildpackage -rfakeroot -i'(.git|build|.gitignore|testing)*' -I.git -
 ifeq ($(version),)
 version=$(shell git tag -l | grep '^[0-9]' | sort -t"." -k 1,1 -k 2,2 -k 3,3 -n | tail -1)
 endif
-deb_version=$(shell git tag -l | grep ^debian-$(release)-[[:digit:]] | sort -t"." -k 1,1 -k 2,2 -k 3,3 -n | tail -1 | sed 's/debian-$(release)-//' | sed 's/@/~/')
+deb_version=$(shell git tag -l | grep ^debian-$(release)-[[:digit:]] | sed 's/debian-$(release)-//' | sort -t"." -k 1,1 -k 2,2 -k 3,3 -n | tail -1 | sed 's/@/~/')
 
 deb=$(package)_$(deb_version)_all.deb
 orig_tarball=../$(package)_$(version).orig.tar.gz