Fix a long standing bug where the XML protocol was wrong. 0.10.2 debian-sid-0.10.2-1
authorAndrew Ruthven <andrew@etc.gen.nz>
Sat, 7 Jul 2012 11:41:35 +0000 (23:41 +1200)
committerAndrew Ruthven <andrew@etc.gen.nz>
Sat, 7 Jul 2012 11:41:35 +0000 (23:41 +1200)
I suspect that a pre-release version of MythTV had 23058 as the
version, and it was changed to 58 at some point in time.

ChangeLog
bin/mythtv-status

index 45f09ad04db272bb7d401297c94f7fa1b166b4d1..a55019a76618ff8ce95f0f94c3d25a4510ab79d4 100644 (file)
--- a/ChangeLog
+++ b/ChangeLog
        If the next recording is in more than 1 day, then switch to showing
        it in days and hours, for example "1 Day, 2 Hours".
 
+       Hrmm, the XML protocol version was wrong for the encoder status,
+       so we incorrectly showed "7" instead of "Recording" for an encoder
+       that was in fact recording.
+
 2012-07-06     Andrew Ruthven
        Correctly handle UTF-8 in the output from MythTV.
 
index d5f1d2317f291150c2a5003059d1f4e9e4f29af4..93ea2505c043363549d8cd883ffcb420b8bc0ed7 100755 (executable)
@@ -238,7 +238,7 @@ my @blocks = (
     'name'  => 'Encoders',
     'type'  => 'xpath',
     'xpath' => "//Status/Encoders/Encoder",
-    'protocol_version' => [ ">= 44", "< 23058" ],
+    'protocol_version' => [ ">= 44", "< 58" ],
     'attrs' => [ qw/hostname id state connected/ ],
     'template' => "__hostname__ (__id__) - __state____connected__",
     'rewrite' => {
@@ -265,7 +265,7 @@ my @blocks = (
     'name'  => 'Encoders',
     'type'  => 'xpath',
     'xpath' => "//Status/Encoders/Encoder",
-    'protocol_version' => [ ">= 23058" ],
+    'protocol_version' => [ ">= 58" ],
     'attrs' => [ qw/hostname id state connected/ ],
     'template' => "__hostname__ (__id__) - __state____connected__",
     'rewrite' => {